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Section 1 General information

In no event will the manufacturer be liable for direct, indirect, special, incidental or consequential
damages resulting from any defect or omission in this manual. The manufacturer reserves the right to
make changes in this manual and the products it describes at any time, without notice or obligation.
Revised editions are found on the manufacturer’s website.

1.1 Safety information

The manufacturer is not responsible for any damages due to misapplication or misuse of this product
including, without limitation, direct, incidental and consequential damages, and disclaims such
damages to the full extent permitted under applicable law. The user is soley responsible to identify
critical application risks and install appropriate mechanisms to protect processes during a possible
equipment malfunction.

Please read this entire manual before unpacking, setting up or operating this equipment. Pay
attention to all danger and caution statements. Failure to do so could result in serious injury to the
operator or damage to the equipment.

Make sure that the protection provided by this equipment is not impaired. Do not use or install this
equipment in any manner other than that specified in this manual.

1.2 Use of hazard information

ADANGER

Indicates a potentially or imminently hazardous situation which, if not avoided, will result in death or
serious injury.

Indicates a potentially or imminently hazardous situation which, if not avoided, could result in death
or serious injury.

ACAUTION

Indicates a potentially hazardous situation that may result in minor or moderate injury.

NOTICE

Indicates a situation which, if not avoided, may cause damage to the instrument. Information that
requires special emphasis.

1.3 Product overview
The SC4500 controller is available with optional expansion modules:

» EtherNet/IP module—The controller can connect to a PLC through Industrial Ethernet Protocol
including a EtherNet/IP solution. Line, Star and Ring topologies are available.

PROFINET module—The controller can connect to a PLC through the Industrial Ethernet Protocol,
which includes a PROFINET solution. Line, Star and Ring topologies are available.

The SC4500 controller PROFINET and EtherNet/IP modules are applicable to the network topologies
that follow:

* Line (chain) topology—Connects the devices with integrated switches in the field. Refer to
Figure 1.

Star topology—Devices connects to a central switch. Refer to Figure 2.

Ring topology—The network is closed in a ring shape to get redundancy. The media redundancy
protocol (MRP) is used for PROFINET and device level ring (DLR) for EtherNet/IP. Refer to
Figure 3.
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Figure 1 Chain topology

Figure 2 Star topology

Figure 3 Ring topology
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Section 2 Commissioning checklist

Use the checklist that follows to complete the PROFINET or EtherNet/IP installation and
configuration procedure. Do the tasks in the order given.

Task

Completed

Install the module on page 5 in the controller.

(wiring).

Electrical installation on page 7—Make all of the necessary hardware connection

Configure the Ethernet ports on page 8 on the controller

Install the configuration file on page 9 on the PLC environment.

* PROFINET—GSDML file
» EtherNet/IP—ESD file

Configure the PLC environment on page 11

Configure the module on page 27 (PROFINET or EtherNet/IP) on the controller.

Section 3 Installation

ADANGER

A

Multiple hazards. Only qualified personnel must conduct the tasks described in this
section of the document.

3.1 Install the module

ADANGER

A

Electrocution hazard. Always remove power to the instrument before making electrical
connections.

Make sure that the PROFINET or EtherNet/IP module is installed in the controller. Refer to the
documentation supplied with the module.

Notes:

* Make sure that the controller is compatible with the module. Contact technical support.
» Connect the module to the third slot on the right side of controller. Refer to Figure 4.

1 The module is factory installed based on the controller configuration.
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Figure 4 EtherNet/IP or PROFINET module slot

1 Module slot

Configure the controller with 1 or 2 Industrial Ethernet ports based on the network configuration. For
star topologies, configure the controllers with 1 Ethernet port. Refer to Figure 5. For chain or ring
topologies, configure the controller with 2 Ethernet ports. Refer to Figure 6.

Figure 5 Controller with 1 Ethernet port—LAN + PROFINET or Ethernet/IP
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Figure 6 Controller with 2 Ethernet ports—PROFINET or EtherNet/IP only

N.m 13mm

=3[ "3 N-m

[2.21 Ibf-ft]

f?i: IEP
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o

ADANGER

N Explosion hazard. Do not connect or disconnect electrical components or circuits to the
{M equipment unless power has been removed or the area is known to be non-hazardous.

Items to collect:

+ SC4500 controller with PROFINET or EtherNet/IP module installed

+ PLC

+ PROFINET/Ethernet switch (optional, only for star topologies)

* LAPTOP with TIA or PLC environment installed

* PROFINET/Ethernet copper cable

Use a Ethernet copper cable for the connection. The cable is a 4-wire shielded, green-colored cable
that gives 100 Mbps Fast Ethernet minimum at 100 meters maximum. The cables used in industrial

networks are CAT 5, 5E, CAT 6, 6A or CAT 7 category cables. The cables have an
IP66 M12 connector or IP20 RJ45 connector.

Hach supplies two standard cable accessories and a kit that includes the connectors to make a
custom cable. Refer to Replacement parts and accessories on page 43.

Make all of the electrical connections in the PROFINET or EtherNet/IP network. Refer to Figure 7.

1. Connect the SC4500 controller to the industrial switch (M12 - RJ45 cable).
2. Connect the PLC to the industrial switch (RJ45 - RJ45 cable).
3. Connect the Laptop to the industrial switch (RJ45 - RJ45 cable).
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Figure 7 Wiring example

1 PLC

3 SC4500 controller

2 Industrial switch

4 Laptop

Section 4 Startup

1. Supply power to the controller and PLC.
2. Setthe PLC toon.

Section 5 Operation

5.1 Configure the Ethernet ports

Make sure that the Ethernet port configuration in the controller is set to one of the IEP (industrial

Ethernet ports) options.

1. Push the main menu icon, then select Controller > Connectivity > LAN > Ethernet ports.

2. Select one of the options that follow based on the wiring configuration of the controller.

Option Description

IEP only The two Ethernet ports are configured for PROFINET or EtherNet/IP. Port 2 in the
module is enabled. Refer to Figure 6 on page 7.

MIX IEP One Ethernet port is configured for LAN connectivity and the other Ethernet port is
configured for PROFINET or EtherNet/IP. Port 2 in the module is disabled. Refer to

Figure 5 on page 6.

Note: When Mix IEP is selected, LAN port configuration shows in the LAN menu. LAN port
configuration setting is used only for LAN connectivity configuration, not for Industrial Ethernet

port configuration.
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5.2 Install the configuration file

Download the configuration file from the manufacturer's website. Install the file on the

environment.
Note: Make sure to remove the old configuration file before a new configuration file is installed.

5.2.1 Install the PROFINET GSDML file

PLC

An example of installation in TIA (Totally Integrated Automation) portal from SIEMENS PLC software

follows:

Note: Steps that follow is an example. Steps and commands may change based on the installed PLC solution.

1. Select Options > Manage general station description files
2. Search for the folder where the file was saved.
3. Select the file, then click Install.

Manage general station description files
Installed GSDs GSDs in the project

Source path: ‘ C:lUsersipsitja. HACH-LANGE\Documents\ws_RL78\Profinet_Pre Certiﬁcation'.FourthRourl

Content of imported path

D File Wersion Language Status
[ GSDML¥2 4-Hach-5C4500-20210525xml V2.4 English Alreadyinstalled
<] i |

=

| Delete ‘ ‘ Insta ‘ |

Cancel |

When the file is installed, "SC4500 Controller 1 port" and "SC4500 Controller 2 port" are available in

the PLC hardware catalog view. Select OTHER FIELD DEVICES > PROFINET IO >
LANGE > HACH SC4500 CONTROLLERS folder.

10 > HACH
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5.2.2 Install the EtherNet/IP EDS file

An example of installation in Studio 5000 Logix Designer software from Rockwell Automation
Technologies Inc. follows:
Note: Steps that follow is an example. Steps and commands may change based on the installed PLC solution.

1. Select Tools > EDS hardware Installation Tool.
2. Follow the wizard instructions.

3. In the wizard, select the option Register and EDS file(s). Then, select Register a single file and

browse the downloaded ESD file.

Rockwell Automation's EDS Wizard *
Registration g
Blectronic Data Sheet file(s) will be added to your system for use in Rockwell Automation applications. =

+ Register a single file

" Register a directory of EDS files r

MNamed:

|Hach_SC45DD_EtherNetIP_\-"1 05.eds Browse...

* If there is an icon file (ico) with the same name as the file(s) you are registering
then this image will be associated with the device.

To perform an installation test on the file(s), click Next

< fras | Siguiente = | Cancelar

4. Complete the Wizard instructions.

When the file is installed, the SC4500 module is available in the Controller organizer view.
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5.3 Configure the PLC environment

5.3.1 Configure the PROFINET environment
Configure the TIA portal as follows:

1.

Add all of the items that configure the network topology from the Catalog devices.
In the example: the PLC, industrial switch and SC4500 controller.

Select Catalog > Other field devices > PROFINET IO > I/0O > Hach Lange > Hach
SC4500 controller. The PROFINET catalog shows two SC4500 controller modules. Select the
module based on the Ethernet port configured option: 1 port (MIX IEP) or 2 ports (IEP only).

Totally Integratod Automation
PORTAL

=Y

Suich 1
G

<] > 1005 ~

[ Topology view |d Network view [ Device view || Options

8 < |

<l i

-~ -8

[ Foperies

Tainte [& Disgnostis |

o]0

& vz a2
soizoat 117358

3. Add the network connections based on the network topology.

<]
B

=]

5
CIiCT)
ot [ = )

{1 I i

& Topology view [ Network view umDevi:eview I
e HE Qs 24 | | Topology overview [ Topology comparison |
~
¢ Device i port slot Partnersition  Parmnerdevice  Partnerinterface | {
Switch_1 hachsc ey = ¥ 57-1200 station_1 1
csm377 5C4500 contrcll. (@ - Rca 1
assigne o - ~ PROFINETinterface_1 13
Port_1 1X1P1 CSM Switch_t SCALANCE inter...
- oM
~ Switch_1 )
~ SCALANCEinterface_1 01
Por_1 0X11 571200statio.. PLCT FROFINETinterd.
Por_2 oxi12
Port 3 0X13 GSDdeviee !  hachsc Interiace
Port_4 0x14
~ GSD devies_t
~ hechsc 0
- interiace oxt
Port 1 0XIP1 CSM Switch_1 SCALANCE inter.
[v]
<[] [>] [700% ] —5— [<] [ B
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4. Assign the SC4500 controller to the PLC on the Network overview.

» Devices & networks

= Topology view |, Network view  |IIf Device view |
¥ network| £} Connections [ conne | Network overview | Connections | 1O communication | VPN [«]»
7 Device Type Address in subnet | Subnet -
~ 571200 station_t 57-1200 station
PLC1 hachsc = » PLC T CPU 1212C ACIDCRIy
cPuT212C 5C4500 controll... M M
P ~ GSD device_1 GSD device [+]
» hachsc 54500 controller 1 port
PLC_1.PROFINET I0-Syste.
.
=
<[ > [100% ] —f— & < I >

5. On the Online and Diagnostic view, select Assign IP address to set the IP address of the

SC4500 controller.

~ Diegnostics

fssign IP address

General
Diagn:
Channel dis -
» FROFINETinterisce [x1]
~ Functions 1
"
Assign PROFINET device na
Reset to factory settings

For mars

MAC address:

1P address:

Subnet mask:

Router address:

Assign IP address to the device

Devices connected to an enterprise network or directly to the internet must be appropriztely

protected aqainst unauthorized access, =g, by use of firawalls and network segmentation
information sbout industrial security, plesse visit

hitp:ilww.siemens.comiindustrialsecurity

00 -00 -00 -00 -00 -00 | Accessible devices

192.168.0 . 215
255 . 255 . 255 . 0

[0 use router

The parameters were transferred

sgne. |4 Onlinesdia | & Online &di

q ]
| = Properties  |%linfo /2] Diagnostics
|| General | Cross-references | Compile |
.|| [show all messages -
I Message Gowo 7 Date
€@ - swrdownloading to device. 611012021
@ =~ shor2021
(i} ~ Hardware configuration 6/10/2021
[} Hardware configuration was leaded successfully. 6102021 11:48:37 AM
Routing configuration was loaded successfully. 61012021 11:48:37 AM
o PLC_1 sterted. 6102021 11:49:37 AM
The software has not been loaded, because itis up-todate. 61002021 11:48:37 AM |
&  Losding completed (srrors: 0; warnings: 0). 6102021  11:49:37 AM
Search completed. 1 of 3 devices were found 6102021  11:50:23 AM
_Q 11:51:13 AM ~
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6. Select the commands Compile and Download to device on the PLC menu.
The SC4500 controller gets the assigned IP address and the Industrial Ethernet Interface web
page is enabled. The Industrial Ethernet Interface web page gives information about the data sent
through Telegram.

7. On the PLC menu, select Accessible devices view. Then, select Flash LED to identify the
SC4500 controller with the installed module.

The controller display will flash.

Accessible devices in the network:

IP address MAC address Device PROFINET device name Status
192.168.13 00-0E-1C-05-C4-44  hachsc hachsc_1 @ ox
.
(<] ] [2]
’ Update list \ ’ Assign name \

8. When the controller is identified, unselect the option Flash LED.

9. In a web browser, type the IP address to access the Industrial Ethernet Interface web page. The
message "Telegram not defined!" shows.

@ 192.168.0.10/index.html X o+ (-] B = x
€ C A Notsecure | 192.168.0.215 A&
Be Right™

Industrial Ethernet Interface Home Page

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

Telegram not defined!
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10. On the SC4500 controller, go to the main menu. Then, select OUTPUTS > PROFINET >
SIMULATION. Set the simulation to ON.

The controller starts sending simulation values to the PLC. The controller continuously sends a
simulation value in a loop from Minimum to Maximum during the set Period. When the value

gets the Maximum set value, it decreases to the minimum and then again to maximum. Error

and Status values set on the controller are also sent to the PLC.

£ Simulation ®
Simulation Yes > |
Period 2min »
Maximum 20.00 >
Minimum 10.00 »
Error 16 .

11. Go to the Industrial Ethernet Interface Home Page.

€ C A Notsecure | 1921680215 % 2
# Apps €Y Claros-sprint Reading lst
Be Right™

Industrial Ethernet Interface Home Page

Location: 000000113714 MAC address: 00:0E:1C:05:C4:29

Modules assigned

Telegram composition
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12. Select Modules assigned to see the information that the controller sends in simulation mode.

< C A Notsecure | 192.168.0215/ma.html b §

£ Apps ) Claros-sprint Reading list

(racH)

Be Right™

Modules assigned

Location: 000000113714 MAC address: 00:0E:1C:05:C4:29

Simulation Yes

Slot Module Tags from .. to
Input 8 bytes
Input 4 bytes
[Input 2 bytes
[Not assigned
[Not assigned
[Not assigned
[Not assigned

ENE=IES)
U V) pu

] Fooy vy e v ey e

Home

13. Select Telegram composition to see Telegram information on the type of data (integer or float)
and their relative address in the PLC memory.

— o X
B¢ Google Translate X @ 192.168.0.215/tc00html x  + (-]
<« C A Notsecure | 192,168.0.215/tc00.html ¥ A
1 Apps £ Clarossprint 88 Nordic Semiconduc... Reading list

Input telegram composition

Location: 000000113714 MAC address: 00:0E:1C:05:C4:29

Simulation Yes
Tag Type Profinet PLC Input address range
0 float 1[0.3]
1 float 14.71
2 integer 18.9]
3 integer 1[10..11]
4 integer 1[12..13]

Home
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14. Add the inputs modules on the Device overview tab of the PLC based on the Modules

assigned information.

‘E Topology view Hﬁﬁ-,, Network view “_[H Device view ‘ Options (EE]
m X
Device overview 0 5
=
2/ [Module Rack |Slot laddress |Q address | Type v | catalog 3
~ hachsc 0 0 54500 controller ... | [Search= | [t fait) | o
8
EREF N o e et )|
Input 8 bytes_1 0 1 68..75 Input & bytes — =g
> R 2
Input 4 bytes_1 0 2 76.79 Input 4 bytes =
Input 2 bytes_1 0 3 80._81 Input 2 byte: ~ - Module
nput 2 bytes. . s = —
put 2 bytes_ 2 - put 2 by [l Inputs byall slots [
o . Il input 16 bytes °
o . Il input 2 bytes E
o . Il input 32 bytes e
. Il input 4 bytes =
i Il input 64 bytes g
- Il input 8 bytes —
’ ~ [ Inputs by one slot 53
Il slot 1 Input 128 bytes E]
Il slot 2 Input 128 bytes 3
Il Slot 3 Input 128 bytes -
Il slot 4 Input 128 bytes (i}
Il slot 5 Input 128 bytes =
Il Slot 6 Input 128 bytes ]
» [ Outputs 8

15. Add the tags and variables based on the values that the controller simulation sends. Add the
same settings as in the Industrial Ethernet web page. Refer to the table below.

$C4500_Demo » PLC_1[CPU 1212CACDURIy] » PLCtags » Default tag table [42]

@Tags |[@ Userconstants | System constants |
" IE T El
Default tag table
Name Data type Address Retain  Acces.. Writa.. Visibl.. Comment
1 @  simulation_value Real %ID68 =] ™~ (=]
2 @  simulation_Temperature Real D72 =] ~ =]
ERC | ulation_Hearbeat uint BVT6 =] ~ =]
4 @ simulation_Emor uint VT =] ™ =]
5 @ simulaton Stetus [un [5]%meo = =] =] =]
Tags Type Size Slot | Slot size | Input address | Address
1 - Simulation_value Float (Real) |4 bytes %1D68
Slot1 |8 bytes |[68...75
2 - Simulation_Temperature | Float 4 bytes %ID75
3 - Simulation_Heartbeat Integer (Uint) | 2 bytes %IW76
Slot2 |4 bytes |[76...80
4 - Simulation_Error Integer 2 bytes %IW78
5 - Simulation_Status Integer 2 bytes [ Slot 3 |2 bytes | 80...81 %IW80
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16. Select the option Monitor all in the popup menu in the Default table screen. If the connection is
successful, the simulation data from the SC4500 controller shows.

| Devices “@Tags | @ Userconstants @ System constants

4 B A =l

Default tag table

=

BEENEEE
E

INANE0E

Monitorvalue | Comment
17.16565

265

52637

16

5

tebbd

SEEEETH

(<14

17. When the simulation is successful, stop the simulation on the controller. In the main menu of the
controller select Outputs > PROFINET > Simulation. Set the simulation to off.

5.3.2 Configure the EtherNet/IP environment
Configure the EtherNet/IP Studio 5000 Logix Designer environment as follows:

1. On the SC4500 controller, go to the main menu. Then, select OUTPUTS > EtherNet/IP >
Adressing mode. Select Static.
The option EtherNet/IP shows in the EtherNet/IP menu.

2. Select the EtherNet/IP setting and add the IP address of the controller.

Note: Select Static to manually add the IP address of the controller. Select DHCP mode to automatically add
an IP address using DHCP server. Contact your network administrator for more information.

£ EtherNet/IP ) £ EtherNet/IP &
Addressing mode Static > . IP address 192.168.0.10 »
Location 000000116499 » Subnet mask 255.255.255.0 »
Version 1.05 Gateway address 0.0.0.0 >

MAC Address 00:0E:1C:05:D0:AE

Input from PLC
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3. Select OUTPUTS > EtherNet/IP > Simulation. Set the Simulation to on.

The controller starts sending simulation values to the PLC. The controller continuously sends a
simulation value in a loop from Minimum to Maximum during the set Period. When the value
gets the Maximum set value, it decreases to the minimum and then again to maximum. Error
and Status values set on the controller are also sent to the PLC.

£ Simulation ©®
Simulation Yes ?
Period 2min »
Maximum 20.00 >
Minimum 10.00 ¥
Error 32 »

4. Open or create a new project In the Studio 5000 Logix Designer environment.

5. Add the controller module. In the Controller organizer select I/O Configuration > Ethernet.
Right click on Ethernet and select New module.

8 Logix Designer - HACH_CS4500_EDS_SIMULATION in HACH_ONE_MODULEACD [1769-L16ER-BB1B 31.11]*
FILE EDIT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP

DM 8 [ ersisn Gk
= RUN e

= ok 1 Path: AB_ETHIP-11192. 168.0.50 % & 0
9 Energy Storage

=10 offline fl. NoForces b NoEdits

Controller Organizer > 7 x

a %=

4 ] Controller HACH_C54500_EDS_SIMULATION
<7 Controller Tags
Controller Fault Handler
Power-Up Handler
4] Tasks
4 53 MainTask
4 3 MainProgram
<7 Parameters and Local Tags
MainRoutine
Unscheduled
4 = Metion Groups
Ungrouped Axes
b Assets
T Logical Model
4 1 1/0 Configuration
4 B3 PointlO
(D [0] 1769-L16ER-BB1B HACH_C54500_EDS_SIMULATION
4 = Embedded /O
& [1] Embedded Discrete_O
Expansion /0, 0 Modules

@® B Mew Module...

)5_SIMULATION
Import Module..
Discover Modules...
Bus Size
Paste Ctri+V
Properties Alt+Entrar
Print 3

A search window shows.
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In the Catalog tab, add "SC4500" to find the controller module. Select the "HACH
SC4500 Controllers", then select Create.

Select Module Type
Catalog  Module Discovery Favorites
[se4500 Clear Filters Hide Filters &
lodule Type Category Fiters lodule Type Vendor Fiters
M Modue Type C: Filt ~ | Module Type Vendor Fill @
Analog Advanced Ensrgy Industries. Inc
Communication Dialight
Communications Endress +Hauser
Commurnications Adapter FANLC CORFORATION
Controller v FANLC Robotics America v
Catalog Number Description Vendor Category
Hach SC4500 Controllers Hach Lange SA... Generic Device(keyable)
1 of 532 Module Types Found Add to Favorites
[ Close on Create Create Close Help

The New module window shows.

In the General section, add a Name (in the example the controller serial number) and

Description (optional) to identify the controller in the network. Add the controller IP Address.

B Mew Module

- General” General
- Connection
Module Info
Type SC4500 Hach SC4500 Controllers
- Intemet Protocol
- Port Corfiguration Vendor: Hach Lange SARL
Network Parent Local
MName SN116977 | Ethemet Address
Description: (O Prvate Network

(®) IP Address:

(C) Host Name:

Module Definttion
Revision
Blectronic Keying

Connections

Status: Creating

1.005
Compatible Module

Input / Qutput

192.168.1

192

Cancel

X

Help
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8. Push on Change to examine the Module definition. The values must agree with the controller
simulation values: input size 14 SINT.

B Module Definition™ *
Revision: 1 ~ -
Electronic Keying: Compatible Module w
Connections:

Name Size

Input / Output Input: 14

~ SINT
Cutput: o

Cancel Help

9. Go to the Connection section and configure the settings that follow:

* Requested Packet Interval (RPl)}—Sets the PLC update rate in milliseconds. Range: 1.0 to
3200.0 (Default: 10.0). Very low values can flood the network and decrease network reliability.

» Connection over EtherNet/IP—Set to Unicast to decrease the necessary network bandwidth.

B Mew Module *
- General® Connection
- Connection
Module Info
- Intemet Protocol
~ Port Corfiguration r Requested Packet Interval (RP) | Connection over, ot T
Networke ame (ms) EtheriietP nput Trigger
Input / Output 1.0 2]1.0 - 32000 Unicast | Cyelic M
[ trhibit Module:
[]Major Fault On Controller If Connection Fails While in Run Mode
Module Fault
Status: Creating Cancel Help

10. Push OK.
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11.In a web browser, type the IP address to access the Industrial Ethernet Interface web page.

- [m] x
@ 1921680.10/indexhtml X+ (-}

& > C A Notsecure | 192.168.0.10/index.html b 4 a
Be Right™

Industrial Ethernet Interface Home Page

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

Modules assigned

Telegram composition

12. Select Modules assigned to see the information that the controller sends in simulation mode.

- O X
@ 192.168.0.10/mahtml x  + (-]

< C A Notsecure | 192.168.0.10/ma.html & &

Modules assigned

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

Simulation Yes

I C i I Tnput size (Bytes) I Output size (Bytes) |
‘Inpm / Output ‘14 ‘0 ‘

Home

English
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13. Select Telegram composition to see Telegram information on the type of data (integer or float)
and the Input Tag suffix.

= (m] X
@ 192.168.0.10/<00.htm| X +

<« C A Notsecure | 192.168.0.10/tc00.html
Be Right™

Input telegram composition

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

Simulation Yes

Tag Type EtherNet/IP PLC Input Tag suffix
0 [Float 1[0.3]
1 [float 114.7]
2 linteger 1[8.9]
3 linteger 1[10.11]
4 linteger 1[12.13]
Home

14. In the Studio 5000 Logix Designer environment, on the Controller organizer tab, select Tasks >

Main Task > MainProgram > Parameter and local tags. Add the tags based on the Telegram
composition of the simulation.

3 oo Desgner-HACHLCS4500_E05_SMULATION m FAGH_DEO_SIMULATION.ACD (1763 L6ER S81831.11"

- o x
ELE DT VEW SEARCH LOGIC COMMUNICATIONS IOOLS WINDOW HELP
oomlelvaalell e slenlcbs GG GG
= o .
moK 1 Path: AB_ETHIP-1192.168.0.50 L3 « b= fe FAL FSC COP FLL RUE ST STD SIZE CPS »
™ N e »_[voEms @ T T e e e
Contraller Organizer ~ B X i Module Poperti 0 Program Parameters and Local Tags - MainProgram X
&) Scope: | & ManProgam | Show: |4 Tags [~ >
4 Controller HACH_CS54500_EDS_SIMULATION -
S Contolln ogs Name =/ Alas For Base Tag Data Type ) ]
ControllerFault Handler Simulation_ Value REAL 2
Power-Up Handler Simulation Temperature REAL b General
R, > Simulation Hearbeat INT » Data
443 MainTash b Produced Connection
> Simulation Error INT
4 & MainProgram - » Consumed Connection
© Parameters and Local Tags. b Simulation.Status INT 4 Parameter Connections (0:0)
@ MeinRoutine o

Unscheduled
4 I Motion Groups
Ungrouped Axes
> i Assers
o Logical Model
4 1/0 Configuration
4 &Painto
5 (0] 1765-L16ER-8B18 HACH_CS4500EDS_SIMULATION
4 < Embedded /0
1] Embedded Discrete O
Expansion /0, 0 Modules
4 5 Ethemet
(B 1769-LIGER-BE1B HACH_C54500_EDS SIMULATION
DSCASD0SN116499

5 \WioniorTags \EditTags

Communication Software: RLinx Classic

22 English



15. On the Controller organizer tab, select Tasks > Main Task > MainProgram > MainRoutine.
For each parameter of the simulation, add a COP module with the data that follow (refer to the
table below):

* Source—Add the controller name, then the 1.Data based on the bytes size.
* Dest—Add the parameter Tag.
» Length—Add the bit size of the Tag.

@ Logix Designer - HACH_CS4500_EDS_SIMULATION in HACH_DEMO_SIMULATION.ACD [1769-L16ER-B818 31.11]* -
FIE EDT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP
D W & %O 92 < MR N Gl GG

N
=ox S| P e Empvs2 6050 N & o FRL FSC COP FLL A SAT STO SIZE CPS >
« » AIEON Al BT TmerCourtsr pulouipul Compare  ComputeNlaf Wovelogeal _ File/Misc. i

= offine . Nororces b Notds 2

4 Controller HACH_CS4500_EDS_SIMULATION
 Controller Tags: al
Controller Fault Handler
Power-Up Handler
4 Tasks
45 MainTask.
4 & MainProgram
 Parameters and Local Tags
@ MainRoutine

‘SH1164981Datal10]
Simulton_Error
1

0] . 2l
Simulton_Vae Simuistion_Temperature.
1 n 1

Unscheduled
4 Motion Groups
Ungrouped Axes. | |

. Logical Model
4 /0 Configuration
4 E3Pointi0
& [0] 1769-L16ER-BB1B HACH_C54500_EDS_SIMULATION
4 Embedded /0
& [1] Embedded Discrete 10
Expansion I/0, 0 Modules

b Assets | |

4 s Etherat
5 1769-L1GER-BB1B HACH_C54500_EDS SIMULATION
)SCASD0SN116499

Description

Status Scheduled

Number of Routines 1

Main Routine MainRoutine

Fault Routine

Mex Scan

Last Scan

Parent

Scheduled In MainTask

Rung 0of 1

INT, or DINT (it length operand or value Communication Software: RS

Tags Type Size |.Data

1 - Simulation_value Float (Real) 4 bytes 0

2 - Simulation_Temperature Float 4 bytes 4

3 - Simulation_Heartbeat Integer (INT) 2 bytes 8

4 - Simulation_Error Integer 2 bytes 10

5 - Simulation_Status Integer 2 bytes 12
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16. Select the option Go Online.

@ Logix Designer - HACH_CS4500_EDS_SIMULATION in HACH_DEMO_SIMULATION, ACD [1769-L16ER-BB1B 3111]*
FILE EDIT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP

bew e ada 2 ek BB )
B RUN . . S
= ok I Path: AB_ETHIP-11192. 168.0.50 % & f : 1
I Energy Storage _—
= 1o Offline fl. NoForces . NoEdits 2 b Add-On  Alarms
Controller Organizer Go Online i Module Properties: Local (SC45 # Program Paral
ol G Upload... GG NG o N e | O 5 P s
4 ] Controller HACH_CS4500_EDS Sl Download
@ Controller Tags Program Made cop
Controller Fault Handler Source SN116498:LData[0]
Power-Up Handler Run Mode Dest Simulation_Valug
4 Taske Test Mode Length 1
4 53 MainTask Clear Faults
4 L MainProgram ——
<} Parameters and Local Tz :
B MainRoutine Controller Properties
Unscheduled
4 ] Motion Groups
Ungrouped Axes |
3 Assets
T Logical Model |
4 .1 1/0 Configuration
4 B3 Pointl0
{3 [0] 1768-L16ER-BB1B HACH_C54500_EDS_SIMULATION
4 . Embedded /O
@ [1] Embedded Discrete_|0
Expansion /0, 0 Modules
4 Pz Ethemnet
[ 1769-L16ER-BB1B HACH_CS4500_EDS_SIMULATION
18) SC4500 SN116499
17. Select Download.
Connected To Go Online x

Options  General Date/Time Major Fauks Minor Faults  Project Nonvolatile Memory

Conition: The open praject has offine changes that arent in the conroler,

Connected Controller.
Controller Name: HACH_CS4500_EDS_SIMULATION
Controller Type:  1768-L16ER/B CompaciLogix™ 5370 Controller
CommFath:  AB_ETHIP-Tv152.168.0.50
Serial Number:  GODCDBFF
Securty No Protection
Offine Project:
Controller Name: HACH_CS4500_EDS_SIMULATION
Controller Type:  1765-L 16ER-BB1B CompacLogix™ 5370 Controller

File: nitsh\Studio 5000'Projects\HACH_DEMO_SIMULATION ACD
Serial Number: ~ 0DCDBFF
Securty No Protection

Upload Select Fle... || Cancel Help
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18. Select Download.

Download

Download offiine project 'HACH_CS4500_EDS_SIMULATION' to the
controller,

Connected Controller:

MName: HACH_CS54500_EDS_SIMULATION

Type: 1769-16ER,/B Compactiogix™ 5370 Controller
Path: AB_ETHIP-11192.158.0.50

Serial Number:  60DCDBFF

Security: Mo Protection

1 The controller is in Remote Run mode. The mode will be changed to

Remote Program prior to download.

1 DANGER: The controller being downloaded to is the system time
master. Servo axes in synchronized controllers, in this chassis or
other chassis, may be turned off.

1 DANGER: Unexpected hazardous motion of machinery may occur.

Some devices maintain independent configuration settings that are

not loaded to the device during the download of the controller.

Verify these devices (drives, network devices, 3rd party products)

have been properly loaded before placing the controller inte run
mode.

Failure to load proper configuration could result in misaligned data
and unexpected equipment operation.

Cancel Help

19. On the SC4500 controller, go to the main menu. Select OUTPUTS > EtherNet/IP > Status to
examine the connection condition.

£ Status T

Status Running

Event Simulation on

Data order Swapped
OK
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20. Go to Program Parameters and Local Tags. On the bottom of the window, select the tab
Monitor tags. If the connection is successful, the simulation data from the SC4500 controller

shows.

e

@ oo Desgner - RACH Cs4500.£05 Loeo
FILE EDIT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP

vemlslvaaloiell  Jessinh o 6 GG

vode .
A pan e EmPae21880.50 % &0

= Corrotar O
2 ey S O
o > okt a
" Y MainRoutin
: Scope: [ ; ManProgram | Show: [ Tags M3 V]
4" Controller HACH_CS4500_EDS, SIMULATION
e T P T o |

»

Rem Run EX NoForces

9 Contoleags _
Contellr o Handir Smotaton Vloe Lo 16666 0 M
Power-Up Hander s = a2 b Gozr

agme » Simulton Hearbet Loal 038 > Daa
43 Mo b For i
e | Semalaon et Loal 2 ? Produced Connection
» Simulation_Status Local 10 4 Parameter Connections {0:0}

© Parameters and Local Tags
@ MainRoutine

Unscheduled
4 Motion Groups

Ungrouped Axes
b Assets

. Logical Model
4 /0 Configuration
4 @ Pointi0
{ [0] 1769-L16ER-BB1B HACH_C54500_EDS_SIMULATION
4 Embedded /0
& [1] Embedded Discrete 10
Expansion I/0, 0 Moduies

4 s Ehemnet
5 1769-L1GER-BE1B HACH_C54500_EDS SIMULATION
)SCASD0SN116499

Description

Status Scheduled

Number of Routines 1

Main Routine MainRoutine

Fault Routine

Max Scan s3us

Last Scan s

Parent

Scheduled In MainTask

4[5 \Monitor Tags AEdiTass/ | <

21. When the simulation is successful, stop the simulation in the controller. In the main menu of the
controller, select Outputs > EtherNet/IP > Simulation. Set the simulation to off.
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5.4 Configure the module

5.4.1 Configure the PROFINET module

Configure the PROFINET and the Telegram data in the controller to send sensor or device data to
the PLC. Refer to PROFINET Telegram composition on page 38.

Configure the PROFINET settings as follows:

1. Push the main menu icon, then select Outputs > PROFINET > Telegram.

£ PROFINET ®
» Telegram > JT
Status >
Simulation >
Modules assigned >
Location 000000113715 > .
Version 0.31
MAC address 00:0E:1C:05:C4:2C
Input from PLC > B
2. Select Add device. Select one of the available devices. Push OK.
£ Telegram a} 24 ~ Add device *
onfigured > sc4500 (] B
+ Add device > pHD211441502 - pHD sc V2 E
C e > GLDO121560000026 - LDO sc \?

000123456789 - High voltage

I
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3. On the Telegram menu, select the device. Select Add tags.

For this example, the tags that follow are selected: Classified Error, Classified Status 1, Dissolved
oxygen [mg/L], Heartbeat and Temperature [°C]

< Add tag * < Add tag *
Classified Error v| Dissolved oxygen [mg/L] @ °
Classified Status 1 V| Dissolved oxygen [ppm] ()
Classified Status 2 B Heartbeat (v
Classified Status 3 ] - Measurement indicator [%)] | | -
OK OK
£ Add tag *
| Measurement indicator [%] . A

Service indicator [days]
Temperature [°C] 3

Temperature [°F]

4. Push OK, then Save.

5. In the PROFINET menu, select Modules assigned.
The controller shows the slots information used to configure the TIA environment.

'4 PROFINET # £ Modules assigned ®
Telegram > 1 Slot 1 Input 8 bytes
Status > Slot 1 tags from 0
Simulation > Slot 1 tags to 3
"Modules assigned P2 Slot 2 Input 4 bytes
Location 000000113715 3 Slot 2 tags from 3
Slot 2 tags to 4
Slot 3 Input 2 bytes
Slot 3 tags from 4
Slot 3 tags to 4
Slot 4 Not assigned

6. Go to the Industrial Ethernet Interface Home Page.
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7. Select Modules assigned to see the information that the sensor sends.

Be Right™

Modules assigned

Location: 000000113714 MAC address: 00:0E:1C:05:C4:29

Slot Module Tags from .. to
Input 8 bytes 0.2
[Input 4 bytes E
Input 2 bytes 4.4

[Not assigned
[Not assigned

INot assigned
[Not assigned

NG TS D e ey

Home

8. Select Telegram composition to see Telegram information on the type of data (integer or float)
and their relative address in the PLC memory.

&=

Be Right™

Input telegram composition

Location: 000000113714 MAC address: 00:0E:1C:05:C4:29

LDO2 Serial number: 121560000026

Tag Type Profinet PLC Input address range
0 integer 10.1]
1 integer 12 3]
2 float 14.7]
3 integer 1[8..9]
4 float 1[10..13]
Home
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9. Add the inputs modules on the Device overview of the PLC based on the Modules assigned

information.

‘E-? Topology view @ Network view Hﬁ" Device view ‘ Options [EE)

¥ [Module Rack |Slot  |laddress | O address Type v | catalog H

~ hachsc o o 5C4500 controller ... [-Searcha Hmm E

» Interface 0 0x1 hachsc et Pofle: (o> [+][a]|E

Input 8 bytes_1 0 1 68.75 Input 8 bytes » [ S 2

Input 4 bytes_1 0 2 76..79 Input 4 bytes P

Input 2 bytes_1 0 3 80..81 Input 2 bytes e Jﬂume =

= o . ~ i Inputs byall slots o

o p Il input 16 bytes °

o . Il input 2 bytes i

o S Il input 32 bytes 3

Il input 4 bytes 2

" Il input 64 bytes Ny
= Il input 8 bytes =
» « [ Inputs by one slot g
|- Il slot 1 Input 128 bytes ?
Il slot 2 Input 128 bytes 3
Il slot 2 Input 128 bytes | |

Il Slot 4 Input 128 bytes L1

Il slot 5 Input 128 bytes =

Il slot 6 Input 128 bytes s

» [ Outputs 3

10. On the PLC, do one of the steps that follow:

a. Go to PLC tags and select Default tag table. Add the tags and variables based on the
sensor values. Add the same settings as in the Industrial Ethernet web page. Refer to the

table below.

1_SC4500 » PLC_1[CPU 1212C ACDCRIy] » PLCtags » Default tag table [42]

®F D TH
Default tag table
Name Data type Address Retain  Acces.. Writa_. Visibl. Comment
1 4@  LDO_Ermor uint %IWES ™ =] (=]
2 @ DO Status Ulnt %IW70 ™ =] (=)
3 @ Loo_mgi Real %ID72 =] =] =]
4 4@  LDO_Hearbeat uint %IWTE =] ™ (=)
5 |4  LDO_Temperature Rez| %ID78 =] ™ ™
6 Add ne 2] 8 &
Tags Type Size Slot Slot size | Input address | Address
1-LDO_Error Integer (Uint) |2 bytes 68...69 %1D68
2 - LDO_Status Integer 2 bytes | Slot 1 |8 bytes 70...71 %ID70
3-LDO_mg/L Float (Real) 4 bytes 72..75 %IWT72
4 - LDO_Heartbeat Integer 2 bytes 76..77 %IW76
Slot2 |4 bytes
2 bytes
5-LDO_Temperature | Float 78...81 %IW78
2 bytes | Slot3 |2 bytes
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b. Use the data structure to group the data types. Go to PLC data types. Select Add new data
type and add a name for the data type ("SC_data_Type" in the example). Add the Tags and
variables based on the sensor values.

1_SC4500_Structure_demo » PLC_1 [CPU 1212C ACDCRly] » PLC data types » SC_data_type
Devices

5] FE LEE
SC_data_type
Hame Name Data type Defaultvalue | Accessiblef . |Wiita... |Visiblein .. Setpoint | Comme
~ [ ] 1_5€4500_Structure_demo 1 4@ Error Int 0 =] =] (=] =]
B Add new device 2 @ Status Int (=] =] (=] =]
iy Devices & networks 3 @ Measure Real (=] =] =] =]
~ [ PLC_1 [CPU 1212C AC/DORly] 4 l@m  Heartbeat Int (=] =] (=] (=]
[IY pevice configuration 5 4  Tempersture Real =] =] =] (=]
%] online & diagnestics 6 <Add ne

» g Program blocks

» [ Technology objects

» Fai External source files

» [g PLCtags

~ [ PLC data types
B Add new data type
] 5C_data_type

b 55l Watch and force tables

On the Default tag table, add the data structure and select the data type name. Add the
address of the data structure.

Project tree m 4
Devices
& @ |35 7T
Default tag table
Mame Mame Data type Address Retain  Acces.. Writa.. Visibl.. Col
* [ ] 1_5c4500_Structure_demo 4 v scLbo "SC_data_ty. g %1680 IL'
B Add new device ER | Error Int %IWEE
iy Devices & networks = a Status Int AIWT70
~ [ PLC_1 [CPU 1212C AC/DCIRIy] 4 a Measure Real %ID72
[ Device configuration 5 @ Heartbeat Int IVTE
%/ online & diagnostics 6 @ Temperature Real %ID78.
» [ Program blocks 7 dd ne:

» [ Technology objects
» [@ External source files
- [g PLCtags
%5 showalltags
[ Add new tag table
2 Default tag table [38]

~ [ PLC data types

11. Select the option Monitor all in the popup menu in the Default table screen. If the connection is
successful, the data from the SC4500 controller shows.

5.4.2 Configure the EtherNet/IP module

Configure the EtherNet/IP and the Telegram data in the controller to send sensor or device data to
the PLC. Refer to EtherNet/IP Telegram composition on page 40.

Configure the EtherNet/IP settings as follows:
1. Push the main menu icon, then select Outputs > EtherNet/IP > Telegram.

L 4 EtherNet/IP =}
Telegram

EtherNet/IP

Status

Simulation

Module definition
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2. Select Add device. Select one of the available devices. Push OK.

£ Telegram ® 14  Adddevice *

Not configured > sc4500 |: i

+ Add device > pHD211441502 -pHDscV2 [

- Delete device > GLDO121560000026 - LDO sc v
000123456789 - High voltage v

SAVE

3. On the Telegram menu, select the device. Select Add tags.
For this example, the tags that follow are selected: Classified Error, Classified Status 1, Dissolved
oxygen [mg/L], Heartbeat and Temperature [°C].

4 Add tag * < Add tag fm)
Classified Error vl Dissolved oxygen [mg/L] g
Classified Status 1 V| Dissolved oxygen [ppm] ()
Classified Status 2 ) Heartbeat V)
Classified Status 3 ] - Measurement indicator [%] M
OK OK
£ Add tag *

~ Measurement indicator [%]
Service indicator [days]

Temperature [°C] |«

Temperature [°F] | -

4. Push OK, then Save.
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5. In the EtherNet/IP menu, select Module definition.
The controller shows the bytes data based on the selected Telegram tags.

£ Module definition &

Connection Input / Output
Input size (Bytes) 14
QOutput size (Bytes) 0

6. Go to the Industrial Ethernet Interface Home Page.
7. Select Modules assigned to see the information that the sensor sends.

&«

@ 192.1680.10/mahtml x4+

C A Notsecure | 192.168.0.10/mahtml

Be Right™

Modules assigned

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

‘ C ! ‘ Input size (Bytes) | Qutput size (Bytes)

[Input / Output 14 o

Home
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8.

9.

Select Telegram composition to see Telegram information on the type of data (integer or float)
and the Input Tag suffix.

@ 192.168.0.10/c00html x  + (-] - g X
< C A Notsecure | 192.168.0.10/tc00.htm! T A
E‘e Right™
Input telegram composition
Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE
LDO2 Serial number: 121560000026
Tag Type EtherNet/TP PLC Input Tag suffix

0 integer 1[0..1]

1 finteger 112 3]

2 [float 1471

B3 linteger 1[8..9]

i [float 1[10_13]

Home
. »

In the Studio 5000 Logix Designer environment, on the Controller organizer tab, select Tasks >
Main Task > MainProgram > Parameter and local tags. Add the tags based on the Telegram

composition.

& Looi Designer - HACH_CS4500_EDS_SIMULATION in HACH_ DEMO_SIMULATION.ACD [1763-L16ER-BB1B 31.11]* _ o x
EILE EDIT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP

caml@ cvaaloe ves sk ES G e GG

-

moK Y] Pah: A8 ETHIP-1192.168.0.50 & A « I fes FAL FSC COP FLL AUE ST STD SIZE CPS »
™ ). B s a « » TAGEOT Al B TerCouer RO Corpare Compuieniah —Woveogeal . Fleisc. FiB

Scope: [ ; MainProgram | Show: [ Tags

4 Controller HACH_CS4500_EDS_ SIMULATION
© Controller Tags Mame =8l | Alias For Base Tag
ControllerFault Handler > LDO_Error
Power-Up Handler » LDO_Statust
4 Tk LDO_Mesurement mgl
453 MainTask
4§, MainProgram > LDO Heartbeat
 Parameters and Local Tags LDO Temperature
 MainRoutine o
Unscheduled
4 I Motion Groups
Ungrouped Axes
> i Assets

T, Logical Model
4 O Configuraton
4 @ Pointi0
5 (0] 1765-LIBER-518 HACH_CS4500_EDS_SIMULATION
4 Embedded /O
@ [1] Embedded Discrete |0
Expansion /0, 0 Modules
4 g5 Etnemet
2 1769-L16ER-BB1B HACH_CS4500_EDS_SIMULATION
B)SC0SN11689

As an alternative, use the data structure to add the Telegram composition. Refer to .
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10. On the Controller organizer tab, select Tasks > Main Task > MainProgram > MainRoutine.
For each Tag add a COP module with the data that follow (refer to the table bellow):

» Source—Add the controller name followed with the I.Data based on the bytes size.
» Dest—Add the parameter Tag. Initial element to be overwritten by the source.
* Lenght—Number of destination elements to copy.

3 Logi Desioner -HACH_C54500_EDS_SIMULATION i HACH_DEMO,SIMULATION ACD [T65.L1GER 89183111
EILE EDT VIEW SEARCH LOGIC COMMUNICATIONS TOOLS WINDOW HELP
wealelsaaloe DRV N Gl

= S| panse EPs2 16605 ] b el AL o oo FLL mE T ST st ors »
e Wl ofine B. NoForees b NoEdis 2 « » TAGEOR Amms BF TmenCounter TpuOwpR Compare  Compuienialh Wovaogeal  FileiMisc. T

Controller Organizer > B X § Module Propeties: Los

Qa

4 Program Parameters and Local Tags - MainProgram

MainProgram - MainRoutine®

4 Controller HACH_CS4500_EDS_SIMULATION
© Controller Tags:

cop cop
Controller Fault Handler 1164991 Datal0] SN1164991Datalé] Source SNT16499.Datale]
Power-Up Handler LD0_Er LDO_Mesurement_mal LDO_Heartbeat
1 n 1
4 Tasks
4 £ MainTask.

45 MainProgram
O Parameters and Local Togs
0 MeinRoutine
Unscheduled
4 Motion Groups
Ungrouped Axes | |
b i Assets
T Logiea Mol | |
4 /0 Configuration
4 @ Pointio
B (0] 1765-L16ER-8B18 HACH_CS4500_EDS_SIMULATION
4 Embedded /0
o 1) Embedded Discrete O

cop
= SN116499 10ata(10]
0_Temperalure

1

Expansion /0, 0 Modules
4 5 Ethemet
(B 1769-LIGER-BE1B HACH_C54500_EDS SIMULATION
)SCASD0SN116499

Tags Type Size |.Data
1-LDO_Error Integer (INT) 2 bytes 0

2 - LDO_Status Integer 2 bytes 2

3 - LDO_Measurement_mgL Float (Real) 4 bytes 4

4 - LDO_Heartbeat Integer 2 bytes 8

5 - LDO_Temperature Float 4 bytes 10

11. Select the option Go Online.
12. Select Download.
13. Select Download.
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14. Go to Program Parameters and Local Tags. On the bottom of the window, select the tab
Monitor tags. If the connection is successful, the data from the sensor shows.

@ Loaix Designer - HACH_CS4500_EDS.SIMULATION in HAGH_DEMO_SIMULATION.ACD [1763-L1GER. 85183111 - o x
EILE EDIT VIEW SEARCH LOGIC COMMUNICATIONS IOOLS WINDOW HELP

Samlalydaloe jesslnn|GEd e GG

= e .

3 Controller OK. Fq ran s EmPa92188.0.50 & &0 “« I ke FAL FSc COP FLL AUE SRT STD SIZE CPS »

= Sy S O —

=100 Remrun B NoForces b Notdts 2 « » RGEOY Aers B TrerCouer WuOuRu  Compere  Compuienial Wovelogeal  FeMisc. FiE

Controller Organizer &)  Program Parameters and Local Tags - MainProgram < | [JECRL R U SIVERL RN A

T Srow:[A Tags N e £
4 Contrller HACHCS4500_EDS_SIMULATION

9 ContollerTags [ame zEl-fusge Ve « forcemasc » [T
Contrller FaultHandler > 10O iror Lol 0 g ]
Power-Up Handler b LDO_Status! Local 0

PREp el

423 MainTask

4 & MainProgram
& Parametersand Local Tags 100 Termperature Local asouast

LDO_Mesurement_mgl. Local 311627
b LDO_Heartbeat Local 31065

& MainRoutine
Unscheduled
4 Motion Groups
Ungrouped Axes
b Assets
T, Logical Model
4O Configuraton
4 EPointi0
5 (0] 1765-LIBER-BB18 HACH_CS4500_EDS_ SIMULATION
4 Embedded /O
@ [1] Embedded Discrete [0
Expansion /0, 0 Modules

4 85 Ehermet
 1765-LIGER-BB18 HACH _CS4500_EDS SIMULATION
)SCas00SN1161439

Description

Status Scheduied

Number of Routines 1

Main Routine MainRoutine

Fault Routine

Max Scan Sous

Last Scan 18us

Parent

Scheduied In MainTask

< >

5.4.2.1 Configure the EtherNet/IP data structure

Use the data structure to group the data types. When the data structure is used in the Ethernet/IP
module, make sure to set the order in the controller based on the variable type: all float values first
and then all of the integer values.

To configure the EtherNet/IP module with a data structure, do the steps that follow:

1. Dosteps1to3on.

2. On the controller, select Main menu > Outputs > EtherNet/IP > Telegram > [device/sensor] >
Tag list. Use the drag and drop function to change the tag position. Push and hold near the blue
dots icon of the tag, then move the tag to the new position. Move the tags so that the float and
integer values are together.

£ Tag list ©

it 0-Dissolved oxygen [mg/L]

it 1-Temperature [°C]

it 2 -Classified Error

i 3-(lassified Status 1
it 4-Heartbeat
+ Add tag >

- Delete tag >

3. Push OK, then Save.
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4. Dosteps5to8on.

On the Telegram composition, make sure that the Telegram information shows the type of data
(integer or float) in order.
Note: If the data type is mixed in the Telegram composition, the data structure will show an error in the PLC.

Be Right™

Input telegram composition

Location: 000000116499 MAC address: 00:0E:1C:05:D0:AE

LDO2 Serial number: 121560000026

Tag Type EtherNet/IP PLC Input Tag suffix
0 float 1031
1 float 4.7
B integer l[2_9]
5 integer lf10.11]
n integer l[[12.13]
Home

5. In the Studio 5000 Logix Designer environment, on the Controller organizer tab, select Data
Types > User-Defined. Right-click on User-defined, then select New data type. Add the Data
type name and the members based on the Telegram composition.

jcontrolter Organizer

& P rog ragram - MainRol Data Type: Telegram LDO

&
Name: Telegram_LDO
4 Assets ~
4 ] Add-On Instructions
Description:
b & DLR_AOI
b {Z} DLR_Clear_Node_Info
b {Z} DLR_Dec_to_Hex Members:
b {5 DLR Icon Name Data Type Description
b {5} DLR_IP_MAC_Addr to_String Measurement REAL
b 2} DLR_MAC_Compare
b 5 DLR PathToHex Temperature REAL
4 ] Data Types Error INT
4 User-Defined — s
& Telegram _LDO
b 1 Strings Hearbeat INT
b 1 Add-On-Defined Add member.
b 1 Predefined
b r Module-Defined
Trends
T, Logical Model
4 1170 Configuration
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6. On the Controller organizer tab, select Tasks > Main Task > MainProgram > Parameter and
local tags. Select Edit tags, then add the name of the data structure on the Data type field.

v ax

"0 program Parametersana Locat Togs - Minprogrom > [ Ty P

By B

Alas For Base Tag Data Type Description ExtemalAccess  Constant

» SCLDOStatus Nt Read/Wite
b SC_LOO Hearbeat Nt Read/irte
o [u]

I —

6 170-LIGR-5518 HACH.C5450_£05 SMULKTON
Sscicosnions

» \ Wonfor Tags )\ Edit Tags ] <

7. On the Controller organizer tab, select Tasks > Main Task > MainProgram > MainRoutine.
Add a COP module with the data structure.

9 1768-L1GER-BR1B HACH CS4500,EDS SIMULATION
Dsciosiiesn

8. Dosteps11to14on.

Section 6 PROFINET Telegram composition

The format of the PROFINET tags can be integer (2 bytes), unsigned integer (2 bytes) or float

(4 bytes).

The data transmission between the SC4500 controller and the PLC can have a maximum of 7 slots,
where each slot has a quantity of bytes used in the Telegram.

The size of data sent from the SC4500 controller to PLC is calculated with the input modules. The
size of data sent from PLC to SC4500 is calculated with the output modules.

The algorithm in the PROFINET module uses the rules that follow:

» The minimal number of slots are used.

* The byte modules are used from higher to lower without repetition. The modules available are
128 bytes, 64 bytes, 32 bytes, 16 bytes, 8 bytes, 4 bytes and 2 bytes.

» Because the module cannot be higher than 128 bytes and it cannot be repeated, there is one
module of 128 bytes for each slot.

» The maximum capacity of the Telegram is 768 bytes for input data and 128 bytes for output data.
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The Modules assigned option in the PROFINET menu on the controller shows the Telegram
configuration in the SC4500 PROFINET module. The menus show the slots with each input module
and assigned tags. Refer to Figure 8.

For example:

+ 5 tags selected: tag 0 (2 bytes), tag 1 (2 bytes), tag 2 (2 bytes), tag 3 (4 bytes) and tag 4 (4 bytes).

Total 14 bytes.

+ Slot 1. Module Input 8 bytes. Tags assigned to this module: tag 0, tag 1, tag 2 and tag 3 (2 bytes).
+ Slot 2. Module Input 4 bytes. Tags assigned to this module: tag 3 (2 bytes) and tag 4 (2 bytes).
+ Slot 3. Module Input 2 bytes. Tags assigned to this module: tag 4 (2 bytes).

Note: Use the drag and drop function to change the elements on the Telegram list. Push and hold on the element
and move the device or tag to the new position. Make sure to update the PLC configuration accordingly after the

elements are moved.

Figure 8 Example of Modules Assigned and Telegram composition

% 0-Classified Error Stot 1 Input 8 bytes

i 1-Classified Status 1 Slot 1 tags from 0

il 2-Heartbeat Slot 1 tags to 3

& 3-Solids [%] i =
Slot 2 Input 4 bytes

# 4-Solids [mg/L]
Slot 2 tags from 3

+Add tag >
Slot 2 tags to 4

- Delete tag > B I B
Slot 3 Input 2 bytes
Slot 3 tags from 4
Slot 3 tags to 4

Slot4

Tag list @ i< Modules assigned

Not assigned

=}

[ Netorkview [T Device view |

» PLC_1 [CPU 1212CAUDGRYY] > PLCtags b Default tag table [52]

o |1 adares | addres [Type

As an alternative, use the Industrial Ethernet web page to know the assigned slots and the telegram
composition. Use a browser and enter the module IP address. Refer to Figure 9.
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Figure 9 Industrial Ethernet Interface web page
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Section 7 EtherNet/IP Telegram composition

The format of the EtherNet/IP tags can be integer (2 bytes), unsigned integer (2 bytes) or float

(4 bytes).

The data transmission between the SC4500 controller and the PLC is done with an Input/Output
connection. The Input/Output connection is bidirectional. The originator (PLC or HMI) sends data to
the target (SC4500 controller) and the target sends data to the originator. This type of connection is
also called Exclusive Owner connection or Controlling connection.

The input data size is the data sent from the SC4500 to the PLC. The input data size is calculated
based on the tags configured in the controller. The output data size is the data sent from the PLC to
the SC4500. The output data size is 0 bytes if there are no inputs selected and 32 bytes for each

8 selected inputs from the PLC. The maximum capacity of the Telegram is 768 bytes for input data
and 128 bytes for output data.

The input and output size are configured in the Outputs > EtherNet/IP > Module definition view of
the PLC.

For example:

« 5tags selected: tag 0 (2 bytes), tag 1 (2 bytes), tag 2 (2 bytes), tag 3 (4 bytes) and tag 4 (4 bytes).
Total 14 bytes.

Note: Use the drag and drop function to change the elements on the Telegram list. Push and hold on the element
and move the device or tag to the new position. Make sure to update the PLC configuration accordingly after the
elements are moved.
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Figure 10 Example of Module definition and Telegram composition
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As an alternative, use the Industrial Ethernet web page to know the modules assigned and the
telegram composition. Use a browser and enter the module IP address. Refer to Figure 9

on page 40.

Figure 11 Industrial Ethernet Interface web page
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Section 8 LED status, diagnostic and messages

On the PLC, put the system in Online mode and examine the status of the network.
On the controller, push the main menu icon and select Output > PROFINET / EtherNet/IP > Status.

Examine the Status messages:

» Idle—Module state when the PLC is in stop mode.
» Pending—Configuration process and the connection is opened.
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+ Exception—Unexpected behavior
* Running—Connection is established

As an alternative, examine the LEDs in the PROFINET module.

Figure 12 Module LEDS

1 Network status LED

4 Link/Activity LED

2 Link/Activity LED 5 Port2
3 Module status LED 6 Port 1
Network Module Status PROFINET Event | EtherNet/IP Comments
status status event
LED LED
Off Off The module has no
power.
Off On Pending Waiting Ethernet | Waiting Ethernet | No ethernet cable
Link Link connected to
module
Ethernet cable
plugged on Port
2 in Mix IEP option.
On On Running PLC connection PLC connection | PLC in RUN mode
or Simulation on | or Simulation on | without/with
simulation on.
Blinking Blinking Running Identify node Identify the node
on the Network.
1 flash On Idle PLC in STOP PLC is not in
mode RUN mode
2 flashes On Pending Broken PLC Broken PLC
connection connection
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Network Module Status PROFINET Event | EtherNet/IP Comments
status status event
LED LED
3 flashes On Pending Station name not Station Name error
set
4 flashes On Pending IP address not set | Duplicate IP IP address error
address IP
address not set
5 flashes On Running / Telegram not No connections | Configuration error
Pending defined stablished or
Modules assigned | Telégram not
mismatch or defined
Head module
mismatch or PLC
slots not set
2 flashes 2 flashes Exception Unexpected Unexpected Unexpected error
behavior behavior

Section 9 Replacement parts and accessories

Personal injury hazard. Use of non-approved parts may cause personal injury, damage
to the instrument or equipment malfunction. The replacement parts in this section are
approved by the manufacturer.

Note: Product and Article numbers may vary for some selling regions. Contact the appropriate distributor or refer to

the company website for contact information.

Replacement parts

Description Item no.
M12/RJ45 connector kit (Ethernet cable) LXZ524.99.00009
M12/M12 connector kit (Ethernet cable) LXZ524.99.00010
Ethernet cable M12 to M12, 10 m LXZ524.99.00011
Ethernet cable M12 to RJ45, 5 m LXZ524.99.00012
Accessories
Description Item no.
SC4500 PROFINET upgrade Kit LXZ525.99.C0001
SC4500 EtherNet/IP upgrade Kit LXZ525.99.C0002
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